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Purpose: Microsoft Project (MSP) tracks capital improvement projects. Schedule, 
budgetary information, and construction progress are collected from all Cedar Rapids 
Enterprise Projects and input into Power BI reports visible on the CR Reports Center. 
This SOP shows how to create a new project schedule in MSP and keep it up to date. 
Failure to correctly represent your project schedules will result in inaccurate reporting 
that is visible to other Engineering team members and management. 
 
Scope: Program managers, project managers, and project coordinators connected with 
Cedar Rapids’ Capital Improvement Program (CIP), Construction Contract Coordinators 
and Construction Project Managers, and Right of Way group project managers 
 
Procedures: This SOP outlines steps necessary to create and update project 
schedules, and assumes readers have a rudimentary knowledge of Microsoft Project. If 
you are unfamiliar with this application, review readily available online training material 
for Microsoft Project (desktop version) to ensure your success. 
 
Online Resources: 

• Microsoft Project 2016 Training Tutorial for Beginners 
 
MSP is a powerful program that may be unintuitive to those unfamiliar with Microsoft 
products. Ask for help from coworkers or your Coordinator as you create your first 
schedules to gain a better understanding of how the city uses this tool. 
 
This SOP has two main sections: creating a new schedule, and updating an existing 
schedule. 

http://www.cedar-rapids.org/local_government/departments_g_-_v/public_works/referenced_materials.php#Ch2_References
http://macon/CRReports/browse/Public%20Works%20Projects
https://www.youtube.com/watch?v=_uaFyYIwAyU&list=PLzj7TwUeMQ3g_ABHdUU7RoGJJm-YFr4_Y
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Creating a New Project Schedule 
 
At the beginning of any CIP project, as soon as a PSA is approved or a budget and 
schedule have been approved, a schedule should be created for it in MSP. Have this 
information available to help you create the Project. Note that all project information will 
be updated as the Project progresses. 
 
Creating a new schedule in MSP includes the following: 

1. Open MSP 
2. Create a new schedule 
3. Fill out Project Information 
4. Eliminate unnecessary tasks 
5. Add tasks not provided for by the template 
6. Update the Schedule 
7. Set the Baseline 
8. Save 
9. Set permissions 
10. Publish 
11. Close and Check-In 

 
The following is an expanded explanation for the above: 
 

1. Open Microsoft Project 
a. If this has not been installed on your machine, ask your supervisor to 

request a license through IT. 
b. If this is the first time you’ve run the program, you may need to connect to 

the network. If you don’t see Cedar Rapids as an option, refer to SOP – 
Microsoft Project Connecting to Server 

 
2. Create a new Project. 

a. Go to New > Enterprise 
b. Select the template applicable to your project type. “Engineering_PDMM” 

will be used for most Engineering projects, as it follows the PDMM. 
Additional templates are available for specific project types:  

i. PFP-Streets_2022 is a template for PFP Streets Projects that only 
show a construction scope 

ii. FCS Tracking Template is used by the Flood Control System group 

file://///citycr.local/SHAREDOCS/PWAdmin/SUPPORT/DEPT%20PLANS%20AND%20OPS/SOPS/3FINAL/PW_ENG_SOP_MICROSOFT_PROJECT_CONNECTING_TO_SERVER_F.docx
file://///citycr.local/SHAREDOCS/PWAdmin/SUPPORT/DEPT%20PLANS%20AND%20OPS/SOPS/3FINAL/PW_ENG_SOP_MICROSOFT_PROJECT_CONNECTING_TO_SERVER_F.docx
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iii. Road Construction Schedule is used by the Construction group 
iv. The Right of Way group uses templates identified by “ROW” which 

are specific to their projects. Do not use these for engineering 
projects 

 

 
 

3. Fill out Project Information. With the new schedule in front of you, in the ribbon 
up top, go to Project > Project Information, 

 
 
Fill out the following fields: 

• Project Type (CIP, PFP, Flood, Federal, Sewer Engineering, etc.) 

• Anticipated construction start date, if applicable 

• Anticipated construction duration, if applicable 

• Project Status (begin with “on schedule”) 

• Project Phase (normally begins with design) 

• Project Title (as shown on the PSA or other council documents) 

• Project Number (CIP Number) 

• Project Scope (as shown on the PSA or other council documents) 
 

You may also have information pertaining to the following; if so, you should enter it to 
support project reporting: 

• Quadrant work will be performed in 

• PM (Project Manager) overseeing the project 

• Consultant (as shown on the PSA or other council documents) 
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• Consultant Contact (as shown on the PSA or other council documents) 

• Lane Miles (mileage x number of lanes) 

• Mileage (straight line mileage within project limits) 

• Original PSA ($ value, as shown on the PSA, if applicable) 

• PSA Contract End Date (if applicable) 

• Parcel Count (an estimate is acceptable and can be updated later) 
 
 

Edit the top row of the schedule to show the project’s name. 

 
 

4. Review the schedule template and identify which tasks, if any, should be 
inactivated or removed. The Engineering_PDMM template assumes the full 
design process is completed following the PDMM. If you have a smaller project 
or are not working with a consultant, not all steps may be necessary. For 
example, if your project has a PSA but not a functional design, you would 
inactivate the functional design section. See image below with the “Inactivate” 
button marked in red. 
 

 
 
 

a. Adjust Predecessors. Some tasks, like Open Houses, are minimally 
constrained because their timing is less critical than, for example, the 
preliminary assessment process. Set predecessors or manually constrain 
tasks based on your PSA Schedule or Project Schedule. If you are not 
comfortable doing this, reference online learning materials. 
Note: Do not modify Parent Task due dates or durations. Parent tasks 
(which have sub-tasks beneath them) are representative of the duration 
and Start/Finish dates of the tasks beneath them. 
 

5. Add additional tasks as necessary. 
a. If the project contains additional meetings, tasks, or steps that would be 

helpful to track the project schedule, add them. Make sure to update 



5 

 

Predecessors as applicable. 
 

b. WARNING: Do not change the names of existing Tasks; if you add 
new tasks that should show in Power BI reports, notify the 
Coordinator(s) managing Power BI. 
Power BI reports pull Task Names as written in the Engineering_PDMM 
Template for reporting. If a Task Name is changed (adding notes, re-
wording, etc.), it will not show up n the Power BI Report unless the 
Coordinators managing the Power BI report, or IT, update the Report to 
look for the new language in your Task Name. 

 
In the event you have duplicates of a task (e.g. your project ends up 
having two intermediate turn-ins), this is ok. The report will know to look 
for the newest (chronologically) version of the task and will report those 
dates. 

 
6. Update the Project Schedule. For each task, review and adjust the Duration 

column so that the Start and Finish dates align with your Project Schedule. Note 
that by default, the Duration column is set to working days - five days duration 
equates to five business days, not five calendar days. 
 
Example: your design start date is 4/24/20. You want your consultant to turn in 
their Functional design on 6/19/20, and you intend to give City staff until 7/10/20 
to finish their reviews. Here is your starting point: 
 

 
 
You’re going to add enough days to get the Finish dates where you want them. 
To do this, you would need to increase the Duration of ‘Work on Design’ to 41 
days, and your review tasks to 15 days. If you notice, this also impacts the Start 
and Finish dates of downstream tasks connected to Functional design when you 
do this. 
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Tasks with a Duration of 0 days, such as ‘Functional Design Complete,’ are 
considered milestones. They don’t have a duration assigned to them because no 
work is actually being done; they’re a reference point used in Power BI reports 
and should not be changed. 
 
Special Durations 
Certain tasks, like those related to Council dates (Filing, Public Hearing, 
Acceptance), have their own special calendar they follow. Each “day” on the 
Council calendar is one Council meeting, so two “days” for that task may equate 
up to a month in calendar time. 
 
The bid letting and Council documents turn-in tasks also follow their own special 
rules, so don’t be surprised if adding more than one or two days to their duration 
has a big impact on your schedule. 
 

7. Set the Baseline. Once the Tasks and Start/Finish dates match your PSA or 
project schedule, set the Baseline. Baselines are used to track slippage in a 
project that are due to discovery work, project delays, or anything that would 
cause the project schedule to shift. Baseline information can be pulled from 
Microsoft Project into Power BI for understanding where slippage occurs in 
Engineering projects (difference from planned finish dates to actual finish dates). 
 
Go to the ribbon up top and choose Project > Set Baseline > Set Baseline 

 
 
In the window which pops up, choose “OK.” 
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Up to 10 Baselines can be set, meaning that PSA Amendments or significant 
shifts to the timeline caused by external factors can be tracked to identify what 
caused the project to finish later than initially planned. 
 

8. Save the Project. Go to File > Save As > Cedar Rapids > Save 

 
 
The project ‘name’ should be the construction contract number, not the number 
used for the design contract. If you forgot to enter required information (indicated 
with an asterisk), you will have to do so now. 
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9. Set Permissions. By default, only you will be able to see and edit the schedule 
you’ve just made. To enable others to view/edit, you need to set the appropriate 
permissions. Go to File > Info > Manage Permissions. 

 
 
You will be taken to an internet browser version of MSP. If prompted, enter the 
same login credentials you used to get into the desktop version of MSP (see 
beginning of SOP). In the window which opens, click New. 

 
Click all the permission boxes first, then choose “Project Managers” from the list, 
and then click on the right-arrow button. This gives read-write permissions to all 
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Cedar Rapids users. If you want to clamp down access and editing permissions, 
you can choose individuals rather than use the Project Managers grouping. 

 
 
Click Save. You can now close the internet browser and return to the desktop 
client. 
 

10. Publish. You need to publish the schedule in order for others to be able to see 
what you’ve made. Otherwise, the schedule will only be visible to you. Select File 
> Info > Publish. 

 
 
Press “Publish” in the window which pops up. If you get an error message, it is 
likely because another schedule has been created under the same contract 
number.  
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11. Close and Check-In. When you go to close the schedule, you will be asked if 
you wish to “Check-In.” Choose yes. Otherwise, it will remain unavailable for 
editing to anyone except you. 
 

Your new schedule is complete. It will be available to you and others for future viewing 
and edits. 
 
Updating Your Schedule 
 
As your project progresses, you should regularly revisit your schedule to keep it up to 
date. The dates it contains are being used to populate outward-facing reports, such as 
the Upcoming Bid Schedule, and are regularly review by managers to see which 
projects appear to be falling behind schedule.  
 
Each time you open your schedule, you should do the following: 
 

1. Open the schedule 
2. Mark finished tasks as Complete 
3. Inactivate, Add, or Remove tasks as needed 
4. Update expected Finish Dates 
5. Update Project Information 
6. Publish changes 
7. Close and check-in 

 
Here’s an expanded explanation for the above: 
 

1. Open the Schedule in MSP 
a. If you’ve recently worked in the schedule you’re looking for, it may be 

available in the Recent Files list. If not, click on “Open Other Projects” in 
the lower left corner of the screen. 

 
 
 
 
 
Click on Open > Cedar Rapids > Browse > Show me the list of all projects 
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Your project schedule should appear in the full list. If it does not, you may have 
forgotten to either set permissions or publish the project schedule when it was 
created. Ask one of the Project Coordinators to find the schedule and make it 
visible for you. IT can also do this 
 

2. Mark finished tasks as Complete 
a. If a yellow bar identifies the project as being in “Read Only” mode, select 

“Check Out” to make updates to the project. 
b. For tasks that were completed late, first update the correct “Finish” date in 

the column, then mark the Task by selecting the row, navigating to “Tasks” 
in the ribbon, then “Schedule”, and selecting 100%. A task being 100% 
complete will remove it from the Upcoming and Overdue PowerBI reports. 

c. For tasks that were completed on time or have made progress: select 
each applicable row, and in the ribbon under “Task”, “Schedule”, select 
the appropriate approximate percent complete (25%, 50%, 75%, 100%). 

d. If a Task Finish date was extended, this may affect other Tasks in the 
project. You can tell if a date was affected by the cells automatically 
highlighting pale blue when the date is changed. Press F9 to refresh and 
remove this highlighting. 

i. To prevent project slippage, consider decreasing the duration 
(number of working days) of subsequent tasks to make up the 
difference. Make sure the Consultant or other affected parties can 
support the change in schedule. 

ii. Task Durations highlighted green (shown below) are the 
recommended Task durations to change. Tasks highlighted orange 
or with a 0-day duration or yellow with a 1-day duration should not 
be changed, as this will create errors in the schedule and data input 
into Power BI for reporting. 
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Example: a 30% [SJJ1]turn-in was originally scheduled to be complete by 8/21/20. 
The Consultant was a week late, and actually turned in the submission on 
8/28/20. 

 
 
First, update the duration of Work on Design – 30% to reflect the actual turn-in 
date. 

 
 

 
 
In the next image, the duration of a subsequent task was adjusted to keep the 
Baseline Schedule. Continuing the example, the 90% turn-in duration was 
reduced by 5 business days. 

 
 

3. Inactivate, Add or Remove tasks as needed. Tasks in the project may change. 
a. If a Task is no longer required for the project (for example, a permit or 

review from a specific city group), inactivate the task to remove it from the 
project and project timeline. 

b. If a Task or Tasks need to be added, insert rows and apply the 
appropriate predecessors to those tasks so they work with the project 
schedule. 
Note: these added tasks will NOT show in Power BI reports unless you 
specifically notify the Coordinator managing Power BI reporting to add 
those Tasks; the Power BI reports currently filter for specific Task names. 

c. Remove Tasks only if there is no value maintaining a record of the Task; 
inactivating a Task shows that the removal was purposeful, and not just a 
neglected step. 

 
Follow the directions for adding tasks and deleting tasks found in the Creating a 
New Schedule section to achieve what you need. 
 

4. Update expected task Finish Dates. Account for schedule changes by adding 
or removing days to subsequent Task Durations, just as you did when you 
created the Project. Remember, changes you make to one Task will affect 
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downstream Tasks, potentially including your Bid Date or Construction Start 
Date. 
Note: to view project slippage, you can compare your Baseline Start and Finish 
Dates for specific Tasks to the Start and Finish (actual/scheduled) dates. 

 
a. Pay attention to the Task Mode and Task Calendars, shown in the two 

leftmost columns. Manually scheduled (versus Automatically scheduled) 
tasks will affect how Tasks are scheduled, and any calendars applied to 
the tasks (shown in the (i) column, which include Publishing Dates, 
Council Dates, Joint Utility Meeting dates), will also affect scheduling. If 
dates with Calendars appear to be incorrect, contact your Consultant for 
the corresponding Calendar to be updated. 

b. If you want to shift a task within an allowable time range, consider 
adjusting the Constraint type, found under Task Information. The task can 
be scheduled As Soon As Possible, As Late As Possible, and to Start or 
Finish No Earlier or No Later than specified dates. 

c. Reference the Notes column to learn about any specifications relevant to 
the task or its scheduling. 

 

 
 
 
 
 

5. Update Project Information. On the Ribbon, navigate to Project > Project 
Information. 
 

 
 
Update any Custom Fields that have changed. This may include the Anticipated 
Construction Start Date or duration, Project Status, Project Phase, EOPC, PSA-A 
cost or count, Parcel Count, or any of the other fields. 
- If a Custom Field has an asterisk (*), it is a required field. 
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- Note that all Custom Fields are visible in Power BI reports, and inaccuracies 
here will display in reporting. 

 
6. Publish changes. After you are finished, navigate to File > Info > Publish. 

Publishing also Saves changes. Without Publishing, the changes you make will 
not be visible to others. 

 
 

7. Close and Check-In. When you close the project, you will be asked if you wish 
to “Check-In.” Select “yes”. If you do not, it will be inaccessible to others for 
editing until you check it in, or a Coordinator or their designee force checks the 
project in. 

 
 

 


